PDA

View Full Version : Trouble installing DReaM on Mandriva 2008.0


kldrm
06-01-2008, 15:35
Hi everyone,

I am a beginner both in Linux and in DRM.

I am trying to install DReaM 1.2.4-1 from the source RPM provided on the sf.net webpage.

qwt, fftw and libjournaline all seem to install flawlessly.

hamlib does not complain too much, either, but when I attempt to install DReaM itself, it says hamlib-devel is missing. (I could not find any suitable hamlib-devel package for my distro). I think the devel part is also included in the downloadable rpm so it should have installed itself.

faad is the trickiest: neither of the commands given in the Installation instructions seem to work
rpmbuild --rebuild faad2-patch_20060124.txt
rpmbuild --rebuild faad2-patch_20060124.txt --define without_xmms=1


Could anyone please tell me how to install faad - with the patch file given of course -, and also how to get the hamlib-devel package up and running.



Thanks a million in advance,

L

simone
06-01-2008, 16:50
Hi kldrm,

the Dream RPM you mention is quite old, better try to install the latest cvs version (1.10.6cvs).
I can send you details about faad and hamlib later.

Simone

kldrm
13-01-2008, 21:17
Hi kldrm,

the Dream RPM you mention is quite old, better try to install the latest cvs version (1.10.6cvs).
I can send you details about faad and hamlib later.

Simone

Dear Simone,
Dear All,

I managed to get the missing dependencies, hamlib-devel and xmms-devel.

Let Round 2 begin, here is what I execute:


cd ~/inst/src_rpm

rpm --rebuild fftw-2.1.3-8.src.rpm
rpm -Uvih /usr/src/rpm/RPMS/i586/fftw-*.rpm
rpm --rebuild libjournaline_0.20040318_2.src.rpm
rpm -Uvih /usr/src/rpm/RPMS/i586/libjournaline-*.rpm
rpm --rebuild qwt-4.2.0-1.src.rpm
rpm -Uvih /usr/src/rpm/RPMS/i586/qwt-*.rpm

cd ~/inst/bin_rpm
rpm -Uvih hamlib-1.2.4-1.src.rpm # creates a tarball and a spec
cp *hamlib*spec /usr/src/rpm/SPECS/
cp *hamlib*gz /usr/src/rpm/SOURCES/
rpmbuild -ba /usr/src/rpm/SPECS/hamlib.spec

rpm -Uvih hamlib-devel-1.2.4-1.i386.rpm


Apparently everything OK up to this point.

Now how do I patch faad2?

The below try was unsuccessful:

patch -p0 faad2-patch_20060124.txt < faad2_2.0.1cvs2006124_1.src.rpm
patch unexpectedly ends in middle of line
patch: **** Only garbage was found in the patch input.


Is it possible that the patch file provided is broken or am I doing something wrong?
Could it be that I need to patch one of the files created by saying the following:

rpmbuild --rebuild faad2_2.0.1cvs2006124_1.src.rpm
# [...] output omitted for brevity
Wrote: /usr/src/rpm/RPMS/i586/faad2-2.0.1cvs2006124-1.i586.rpm
Wrote: /usr/src/rpm/RPMS/i586/faad2-devel-2.0.1cvs2006124-1.i586.rpm
Wrote: /usr/src/rpm/RPMS/i586/faad2-xmms-2.0.1cvs2006124-1.i586.rpm
Wrote: /usr/src/rpm/RPMS/i586/faad2-debug-2.0.1cvs2006124-1.i586.rpm

simone
14-01-2008, 16:17
Hi kldrm,
just use the source RPM provided on the dream installation page, I also sent you an email
Simone